Jump to content


lags in game


5 replies to this topic

#1 dwhite

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 05 February 2017 - 02:41 PM

hey all, im having a big problem with peakangle.
it's lagging, the game is not smooth while drifting, sometimes freezing, but points do count.
how can i remove this lag, please help me guys.
here is my pc stats.
gpu is nvidia geforce gt 610
Posted Image

#2 SilverSpurs

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • LocationJakarta, Indonesia

Posted 06 February 2017 - 07:52 AM

View Postdwhite, on 05 February 2017 - 02:41 PM, said:

hey all, im having a big problem with peakangle.
it's lagging, the game is not smooth while drifting, sometimes freezing, but points do count.
how can i remove this lag, please help me guys.
here is my pc stats.
gpu is nvidia geforce gt 610
Posted Image

Have you tried lowering the graphic setting? Or maybe disabling smoke effect? Smoke effect kinda slows down the performance by quite a lot.
'Cause I drift with the wind; no one cares where I go.

#3 dwhite

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 06 February 2017 - 07:13 PM

View PostSilverSpurs, on 06 February 2017 - 07:52 AM, said:

Have you tried lowering the graphic setting? Or maybe disabling smoke effect? Smoke effect kinda slows down the performance by quite a lot.
lowest set, still lags. maybe download some game booster or smth similar?

#4 dwhite

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 16 February 2017 - 10:00 AM

is this pc is to low to run this game without lags?

#5 SilverSpurs

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • LocationJakarta, Indonesia

Posted 17 February 2017 - 09:16 AM

View Postdwhite, on 16 February 2017 - 10:00 AM, said:

is this pc is to low to run this game without lags?

I'm sure your PC can run the game on approximately medium-high setting. Have you checked if there's any background program running? That thing usually slows down your PC no matter how beefy your rig is.
'Cause I drift with the wind; no one cares where I go.

#6 shauny

    Member

  • Members
  • PipPip
  • 19 posts
  • LocationCanada,Qu├ębec

Posted 02 March 2017 - 08:24 AM

If you have windows 10 I would recommend at first to turn off xbox apps and disable Game DVR in the option of "Xbox Accessories" apps.
Note: you must download the apps "Xbox Accessories" from microsoft apps store to get to this setting.
Just that will free a bit of memory and you will notice it instantly less lag and 30% gain of FPS while gaming.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users